User Tools

Site Tools


doc:release-notes-mswin:x2goclient-4.0.2.0

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
doc:release-notes-mswin:x2goclient-4.0.2.0 [2014/06/08 01:32]
mikedep333 Release 4.0.2.0+build4 (forgot to update the links)
doc:release-notes-mswin:x2goclient-4.0.2.0 [2014/06/08 01:49] (current)
mikedep333 All users of prior versions should update.
Line 5: Line 5:
 On 2014-06-08, 4.0.2.0+build4 was released with the following changes: On 2014-06-08, 4.0.2.0+build4 was released with the following changes:
  
-  *Cygwin OpenSSL was updated from 1.0.1g-1 to 1.0.1h-1. This fixes the security vulnerabilities in the OpenSSL Security Advisory [05 Jun 2014]: CVE-2014-0224,​ CVE-2014-0221,​ CVE-2014-0195,​ CVE-2014-0198,​ CVE-2010-5298 & CVE-2014-3470+  *Cygwin OpenSSL was updated from 1.0.1g-1 to 1.0.1h-1. This fixes the security vulnerabilities in the OpenSSL Security Advisory [05 Jun 2014]: CVE-2014-0224,​ CVE-2014-0221,​ CVE-2014-0195,​ CVE-2014-0198,​ CVE-2010-5298 & CVE-2014-3470
  
-All users of 4.0.2.0 are strongly encouraged to update to 4.0.2.0+build3. This includes users of the "​misc"​ fonts and "​full"​ fonts builds.+All users of 4.0.2.0+build3 and earlier ​are strongly encouraged to update to 4.0.2.0+build4. This includes users of the "​misc"​ fonts and "​full"​ fonts builds.
  
 ===== Security Update: 4.0.2.0+build3 ===== ===== Security Update: 4.0.2.0+build3 =====
Line 15: Line 15:
   *Win32 OpenSSL was updated from 1.0.1g to 1.0.1h. This fixes the 6 security vulnerabilities in the OpenSSL Security Advisory [05 Jun 2014]: CVE-2014-0224,​ CVE-2014-0221,​ CVE-2014-0195,​ CVE-2014-0198,​ CVE-2010-5298 & CVE-2014-3470   *Win32 OpenSSL was updated from 1.0.1g to 1.0.1h. This fixes the 6 security vulnerabilities in the OpenSSL Security Advisory [05 Jun 2014]: CVE-2014-0224,​ CVE-2014-0221,​ CVE-2014-0195,​ CVE-2014-0198,​ CVE-2010-5298 & CVE-2014-3470
  
-All users of 4.0.2.0 are strongly encouraged to update to 4.0.2.0+build3. This includes users of the "​misc"​ fonts and "​full"​ fonts builds.+All users of 4.0.2.0+build2 and earlier ​are strongly encouraged to update to 4.0.2.0+build3. This includes users of the "​misc"​ fonts and "​full"​ fonts builds.
  
 ===== Security Update: 4.0.2.0+build2 ===== ===== Security Update: 4.0.2.0+build2 =====
Line 23: Line 23:
   * VcXsrv was updated from 1.4.3.1 to 1.4.3.2. The difference is that VcXsrv 1.14.3.2 has backported fixes for X.Org vulnerabilities CVE-2014-0209,​ CVE-2014-0210,​ and CVE-2014-0211. (All are from May 13, 2014) (Note that we have not determined whether or not X2Go could actually trigger them. They are however now fixed in the VcXsrv code.)   * VcXsrv was updated from 1.4.3.1 to 1.4.3.2. The difference is that VcXsrv 1.14.3.2 has backported fixes for X.Org vulnerabilities CVE-2014-0209,​ CVE-2014-0210,​ and CVE-2014-0211. (All are from May 13, 2014) (Note that we have not determined whether or not X2Go could actually trigger them. They are however now fixed in the VcXsrv code.)
  
-All users of 4.0.2.0 are strongly encouraged to update to 4.0.2.0+build2. This includes users of the "​misc"​ fonts and "​full"​ fonts builds.+All users of 4.0.2.0 ​and earlier ​are strongly encouraged to update to 4.0.2.0+build2. This includes users of the "​misc"​ fonts and "​full"​ fonts builds.
  
 ===== Major Windows-specific changes since 4.0.1.3+build2 ===== ===== Major Windows-specific changes since 4.0.1.3+build2 =====
doc/release-notes-mswin/x2goclient-4.0.2.0.1402191170.txt.gz ยท Last modified: 2014/06/08 01:32 by mikedep333