User Tools

Site Tools


wiki:development:build-howto-linux:x2goclient

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
wiki:development:build-howto-linux:x2goclient [2011/11/15 10:46]
sunweaver
wiki:development:build-howto-linux:x2goclient [2020/05/28 22:52] (current)
danger89
Line 1: Line 1:
-====== Build X2GoClient ​& X2Go Browser Plugin for GNU/​Linux ​======+====== Build X2GoClient ======
  
-//... esp. applies to installation on the Linux-From-Scratch distribution./​/+Install ​the following package dependencies first (Debian/Ubuntu based distros):
  
-  * recommended on the client: pulseaudio +<​code>​ 
-  ​* ​build dependencies (libraries and corresponding ​dev/header files): ​ +sudo apt-get install ​build-essential libc6-dev \ 
-    * libc6 +                     qt4-dev-tools libqt4-dev libqt4-network git \ 
-    ​* ​libcups2 +                     libqt4-svg libqtcore4 libqtgui4 \ 
-    ​* ​libgcc1 +                     ​libldap2-dev libssh-dev libxpm-dev ​libcups2-dev \ 
-    * libldap-2.4-2 +                     ​libgcc1 libldap-2.4-2 ​libssh-4 libstdc++6 libx11-dev 
-    * libqt4-network +</​code>​ 
-    * libqt4-svg + 
-    * libqtcore4 +//Note:// Try to use at least libssh >= v0.4.7. 
-    * libqtgui4 + 
-    ​* ​libssh-4 (>= 0.4.7) +//Note #2:// Recommended package on the client-side: pulseaudio
-    * libstdc++6 +
-    * libx11-6+
  
-<​note>​You need qt4 for x2goclient. Follow the installation instructions at [[http://​www.linuxfromscratch.org/​blfs/​view/​svn/​x/​qt4.html|BLFS]].</​note>​ 
  
 **Run the following commands as a regular, non-root user.  You'll need the root password to install them.** **Run the following commands as a regular, non-root user.  You'll need the root password to install them.**
  
-**1. FIXME -> nxproxy ​has to be installed from nx-libs.git +==== 1. Install nxproxy ==== 
-Install nxproxy from git**+ 
 +You can either install it directly via the package manager, like when using APT: 
 + 
 +<code>apt install ​nxproxy</​code>​ 
 + 
 +**OR** 
 + 
 +Install nxproxy from source:
  
 <​code>​ <​code>​
-$ git clone git://​code.x2go.org/​nxproxy +$ mkdir ~/x2go && cd ~/x2go 
-$ cd nxproxy+$ git clone  git://​code.x2go.org/​nx-libs.git 
 +$ cd nx-libs/nxproxy
 $ autoconf ​ $ autoconf ​
 $ ./configure --prefix=/​usr $ ./configure --prefix=/​usr
-$ make +$ make -j 4 
-su -c "make install"+sudo make install
 </​code>​ </​code>​
  
  
-**2a. +==== 2. Install x2goclient from git ====
-Install x2goclient from git**+
  
 <​code>​ <​code>​
Line 41: Line 45:
 $ cd x2goclient $ cd x2goclient
 $ export PREFIX=/usr $ export PREFIX=/usr
-$ make build_client && ​make install_client+$ make -j 4 
 +$ sudo make install_client
 </​code>​ </​code>​
  
-**2b. 
-Also build+install x2goplugin** 
  
-<​code>​ 
-$ make build_plugin && make install_plugin 
-</​code>​ 
  
  
  
wiki/development/build-howto-linux/x2goclient.1321353963.txt.gz · Last modified: 2013/03/08 13:31 (external edit)